contact us

Use the form on the right to contact us.

You can edit the text in this area, and change where the contact form on the right submits to, by entering edit mode using the modes on the bottom right.

Blog

Classic Velocity Blog

On Getting Grounded

Classic Velocity

grounded-boy.jpg

The theme in the garage this week has definitely been grounding. Thematic story number one took place when I found myself locked out of my house but in the garage, and without a vehicle to leave the premises. It was cold outside, but I had a gas heater. The garage doors were blocked by a vehicle outside. A vehicle to which I did not currently have the keys, so I was effectively grounded and sent to my room. It took me a minute to realize that this grounding was not such a bad sentence. I had tools, adult beverages, and a long list of chores to do in the space to which I was confined. I also had several hours until I could get in the house unless I called a locksmith. Hell, I had been actively trying for some time to engineer this kind of quality time. Brilliant.

Thematic story number two involves the turn signals on the CB360. They came on solid, and would not blink. Same, both sides. Common causes of this condition include mismatched bulb wattages, the flasher itself going bad, and a weak battery. I connected the charger to the battery and got normal flashing. Aha, I thought,  weak battery confirmed. However, once it was fully charged, I got slow flashing and then no flashing. Hmmm. I went and found another thermal relay, and witnessed the same slow flashing and non flashing behavior. Could I have 2 bad flashers? Possible, given my inventory habits (see hoarding for Gearheads), but not likely. I began tracing the ground from the flasher and along the way I encountered a major grounding point on the frame spine. I removed all five grounds, sanded them and the frame, and put everything back together. I was acting based on past experience with a Norton. Although this ground had no direct connection to the flasher, and did not appear corroded, my turn signals immediately worked fine. I went looking for other grounds and did the same cleanup just on principle.

image.jpg

Thematic story number three involves the fog lights on the GMC Sierra. They had been mounted for a while, but not connected. This is a pretty simple job of routing the wires, mounting a relay, and then a light switch. The kit that came with the lights seemed more than adequate. After running all of the wiring and flipping the switch, nothing....Then as if by delay, the right one came on ten seconds or so later. No left. I flipped the switch a few times, and the delay went away, but still no left. I went over all of the connections with the test light, and juice was getting to all the right places. Direct leads to a battery made the left light up, so I knew it was good. Just as I was about to conclude that I had some kind of funky relay, I accidentally bridged the ground connection to the frame, and voila, left light. I dismounted the lights, scuffed up the lower bumper connection points and remounted. Perfect left and right lights every time ! 

Strangely, all three of these events happened within a three day period, and did not involve any rusty British vehicles. I am left to wonder how many times over the years I have failed to properly diagnose a ground fault. Best not to know really...However, there should be some universal cure for bad grounds other than rewiring the vehicle. I think that you should be able to sink a 50 ft steel pole into the ground and attach it to any point on the frame of the vehicle. That act should immediately cause all grounds to become good. All except positive ground vehicles, which should have the frame connected to a nearby high tension wire.